aeontimeline

Open full view…

Display Fails to Fully Update to Input

tjlanza
Thu, 07 Apr 2016 14:49:34 GMT

When I click on objects on the screen, the Inspector seems to update correctly for the selected item, but nothing else does - the blue highlight doesn't move, clicking on the + item to see child events doesn't work reliably, the green arrow to view relations doesn't work, etc, etc, etc. I am running Windows 10 on a Microsoft Surface 3. I initially thought that Display Scaling may be at issue here. Aeon Timeline 2 may not be reading the inputs correctly; it's generally a problem with older apps that have non-standard UIs, though AT1 never had a problem). However, turning it off didn't have any effect.

tjlanza
Thu, 07 Apr 2016 15:48:33 GMT

I noticed that at least the green arrow does partially respond... the direction flips, and the scroll bar appears as if there were something to display, but nothing actually shows up.

Matthew Tobin
Thu, 07 Apr 2016 16:03:10 GMT

Hi, Thanks for the feedback. I haven't had a chance to test on a Surface yet, but I have a Lenovo Yoga 2 with a touch screen and large resolution, and have not had any issues there. Out of interest, do you have the same issues if you plug in a mouse and use that, or is it specifically related to touch gestures that you are having issues? Matt

tjlanza
Thu, 07 Apr 2016 16:34:14 GMT

The behavior is the same with the trackpad in the keyboard/cover, a finger, or the pen. I wonder if the OS could be at fault... Is your Yoga Win10 or Win8?

tjlanza
Thu, 07 Apr 2016 16:49:34 GMT

Also, right-clicking and selecting "Show Event Details" or "Expand Parent Events" has no effect. Neither do the equivalents on the View menu. Rapidly and repeatedly clicking on the green arrow causes the "Add Event" window to open.

tjlanza
Thu, 07 Apr 2016 17:02:48 GMT

Another tidbit that might be helpful... It may be file-related, either complexity or conversion from AT1. I created a new file, populated it with half a dozen events, and was able to view details and child events as expected. The file I've been trying to work with previously is converted from AT1 and significantly more complex. It did work long enough to combine a few events into a parent, before AT2 started misbehaving. It's also not just the two buttons that fail to respond. With the older file, I can't use the timeline scroll bar at the bottom of the window; neither attempting to scroll nor changing the view scope work.

Matthew Tobin
Thu, 07 Apr 2016 17:09:33 GMT

Hi, Definitely sounds like the file then. Any chance you can email it to me at support@scribblecode.com and reference this thread? Obviously the contents will be treated with complete confidentiality - but I understand if that won't be possible. It is 3am here in Melbourne now, so I won't be able to look at it until morning now unfortunately. That's what happens when youlaunch something at 9pm, I guess! Matt

tjlanza
Thu, 07 Apr 2016 17:16:15 GMT

Will do. There's absolutely nothing confidential or proprietary in it.

Matthew Tobin
Mon, 11 Apr 2016 12:30:58 GMT

Hi, I have found and fixed this issue on my local build. I was hoping to get it out today, but it is getting a bit late in the evening (10:30pm now), so I will hold it back tomorrow so I can have a better chance to catch any late night coding errors! Matt

tjlanza
Mon, 11 Apr 2016 12:32:12 GMT

Splendid! Thank you.

Matthew Tobin
Tue, 12 Apr 2016 06:06:11 GMT

Hi, I have just released version 2.0.3, which should resolve this issue for you. Please let me know if the problem persists. Regards, Matt

tjlanza
Tue, 12 Apr 2016 14:46:25 GMT

Looks good! Thanks!