aeontimeline

Open full view…

Settings No Longer Functions

pepperdyne
Wed, 20 Sep 2017 17:45:22 GMT

I made some massive changes to my Timeline and now Settings will no longer allow me to go back into. I'm not sure what to do, this seem to be a bug affecting multiple timelines I have setup.

Craig Schiller
Wed, 20 Sep 2017 18:02:11 GMT

Which settings?

pepperdyne
Wed, 20 Sep 2017 18:17:37 GMT

Specifically "Timeline Settings", I've also discovered I can't use the "Add Entity" button.

pepperdyne
Wed, 20 Sep 2017 18:19:34 GMT

This happened after I stripped all of the Entities out of the timeline, it seems to have broken something.

pepperdyne
Wed, 20 Sep 2017 18:49:17 GMT

I was able to save the whole project by exporting the broken project as a CVS file and importing back into a new Aeon Timeline project file.

Craig Schiller
Wed, 20 Sep 2017 19:04:04 GMT

Very odd. I'm glad you got it sorted out.

razyr
Thu, 21 Sep 2017 13:23:19 GMT

I've had something similar happen in the past. I deleted the Observer role from a timeline, then from that point anytime I would try to add an event, AT2 would crash. Seems that the property wasn't deleted from the sync settings. Matt is aware of the problem and indicated it will be fixed in the next release. You can fix a file that's broken in this way by manually removing the deleted entity properties from your data file. Also, if you ever get in a jam with an AT2 file that seems corrupted, Matt has offered numerous times to manually repair files for customers. Glad you found a workaround.

aeonjess
Thu, 21 Sep 2017 13:44:05 GMT

Hi, I'm glad you found a work around for the problem, however if you still have the original file that was broken, it would be helpful for us if you send it to support@aeontimeline.com . It would help us work out what the problem was, and fix it so it won't happen again. Jess

se1961
Fri, 29 Sep 2017 13:09:57 GMT

Hi Jess! I joined the forum to find a solution to the fact that my Timeline Settings option has disappeared. Essentially what happens is, I try to open Timeline settings and nothing happens-- no window, nothing. I am able to open the entities window, and add them. After reading this thread, I surmise that things went wrong when I deleted the "observer" role from the Timeline settings. I have a fairly detailed timeline that's synced to a Scrivener project, and I would hate to have to create a new timeline, and re-link all the events. I'm wondering if I could sent you guys the file, and you could repair it to me-- and possibly, along the way, better understand the behavior of this bug! 🤣

razyr
Fri, 29 Sep 2017 17:35:34 GMT

Hi there, se1961. I'm sure the AT2 support team would like to get a copy of your file so they can fix the cause in future releases. You should probably send it to them whether you resolve it on your own or not. I too deleted the observer role, then saw bad AT2 behaviour thereafter. If you need a quick fix, you might try these instructions, as sent to me by AT Support a few weeks ago. Note that these instructions are for a Mac. If you're using Windows, substitute NotePad where it says "TextEdit". ``` Create a backup copy of your timeline file. Right-click on your timeline file and choose to Open with TextEdit. Search for the text <Settings> to get you to about the right area in the file Delete the following 4 lines from the file, and then save: <Property> <SyncName>aeonObserver</SyncName> <AeonName>6</AeonName> </Property> ``` Of course, your mileage may differ, but this did solve the problem for me. Welcome to the AT Forum.

se1961
Fri, 29 Sep 2017 17:46:08 GMT

Thank you so much for this suggestion and for the welcome! I checked the file using TextEdit as you suggest, and wasn't able to find those properties. However there are a ton of settings for a project that I did a test-sync with. In that file I may have used other properties that I subsequently deleted in Aeon. It appears that in testing various settings, I have somehow borked the file. I hope they see this thread, and request the file, so they can tell me how to fix it! It's pretty big. Many events and characters. 😳

Craig Schiller
Fri, 29 Sep 2017 18:23:47 GMT

As razyr suggested, you should send them the file (without them having to request it).

se1961
Fri, 29 Sep 2017 18:30:59 GMT

How does this work?

razyr
Fri, 29 Sep 2017 18:46:09 GMT

If you look on the Contact page, you'll see the email address. Just send your timeline to them as an attachment.

se1961
Sat, 30 Sep 2017 12:25:44 GMT

Thank you! Done.

se1961
Sun, 01 Oct 2017 13:20:21 GMT

As you predicted, Matt fixed my file very quickly (THANK you!) with this reply, for those who might experience similar problems (although based on the comment, I think it's unlikely!) "There is a bug in Aeon Timeline where it cannot handle a situation where all "Properties" are deleted from the template. It appears you are the first person to do this, as the bug has existed for several years without previously being reported." 😊 Thanks for all who helped.